Back to overview
Degraded

Service Degradation

Oct 20 at 02:54pm EDT
Affected services
Mobile Web
SignUpGenius Main
v3 API
SignUpGenius - v1/v2 API
SignUpGenius Donations
SignUpGenius Tickets
SignUpGenius Auctions
Email Services
Embed Service
Calendar Service
Webhook Service

Resolved
Oct 20 at 04:40pm EDT

Service Restored
Our services are now fully operational. We've successfully migrated to an unaffected region while AWS resolves their US-East-1 outage. All features are now available with normal performance.

Created
Oct 20 at 02:54pm EDT

We're currently experiencing service issues due to an ongoing AWS outage affecting multiple services in the US-East region. Our team is actively monitoring the situation. We'll update you as AWS resolves the underlying infrastructure issues.